Вход:  Пароль:  
FreeSource: Мусорка/AltLinux?/Sisyphus?/devel?/СтарыеGettextTools ...
Free Source | Каталог | Изменения | НовыеКомментарии | Пользователи | Регистрация |

devel@:

Проблема

> Оказывается, новые gettext-tools незаметно нанесли удар по 20 старым
> пакетам. Этим несчастным для сборки требуется старый autoconf (2.13),
> однако в новых gettext-tools всё большее число макросов завязано на
> autoconf >= 2.50

До кучи ещё ppp, который был успешно захачен субстом :)

Симптомы

+ ./autogen.sh
You should add the contents of
`/usr/share/libtool-1.4/aclocal/libtool.m4' to `aclocal.m4'.
FATAL ERROR: Autoconf version 2.50 or higher is required for this script
automake: configure.in: installing `./install-sh'
automake: configure.in: installing `./mkinstalldirs'
automake: configure.in: installing `./missing'
contrib/shell_utils/Makefile.am:7: `SCRIPTS' is an anachronism
FATAL ERROR: Autoconf version 2.50 or higher is required for this script
error: Bad exit status from /usr/src/RPM/tmp/rpm-tmp.63910 (%build)

Решение

> после вызова aclocal, сделать:
> subst 's,AC_PREREQ(2.50),AC_PREREQ(2.13),' aclocal.m4

Но этого недостаточно, нужно ещё s/m4_ifdef/ifdef/.


Ссылок на эту страницу нет


 
Файлов нет. [Показать файлы/форму]
Комментарии [Скрыть комментарии/форму]
Добавить комментарий: